SOLVED – Sage 300 Error 49153 Cannot Access Database

sage 300 error code 49153

Have you ever received error 49513 while trying to log into your Sage 300 application? At times, unfortunately, while trying to log into your Sage 300 application you may encounter this dreadful error. Wondering why this error occurs? Read below to know more about this error and why it basically occurs.

Reason for Sage 300 Error 49153

Error 49153 is the Sage developers’ code, which occurs when the Sage 300 application fails to connect to the database. This means that your Sage 300 application has launched, however when it tries to connect to the database it is unable to make that connection and the reason can be any. So how do you fix this problem so that your Sage 300 application could connect to the database?

Solution to Fix Sage 3000 Error 49153

In this article sagenumber.support has discussed below two solutions to troubleshoot Sage 300 error 49153.

Solution 1

Step 1: Find out the reason

Before beginning this solution, it is important to first check why your Sage 300 application is unable to make connection with the database. One method is to check whether the database connection error is related to a particular database or all databases. For that you will have to log into the Sage 3000 DBSETUP utility that stores all the connection related details of the database associated with the company in Sage 300. Here are the steps to log into the Sage 3000 utility:

  1. Go to the Start button.
  2. Select All Programs.
  3. Go to Sage and the select Sage 300 2012/2014/2016 (depending on your version).
  4. Select Database Setup.
  5. Now sing on by entering your user ID and password.
  6. Click on OK.
  7. Now you will be able to see all the setup profiles for all your Sage 300 application.
  8. Double click on the desired profile to view its properties.

You will be able to see that the Server listed is in fact the right server name (your Login ID and Password are correct) and also the database is also correct with which Sage 300 tries to connect. Open the database connected with Sage 300 Company.

Click on OK and if you receive the error 49513 then check these settings and correct as required. In case, you get the error for more than one database and also you are sure that its utility settings are correct, the problem could be with the SQL server or with the connection of your computer.

Step 2: Check who all getting the error message

Check if the other Sage 300 application users are also getting this error. If so then definitely the problem could be with the database server. And in case not then the problem could be on a specific computer. If all the users are getting error 49153 then proceed to Step 3.

Step 3: Check if the database server is running

Go to the server console and verify that the server is running. You can check is the server is running by pinging the database server by name.  This will also help you find out if it is visible on other computers on the network. For this, do the following:

  1. Go to the Start button, type in ‘cmd’ and click Enter, a command box will appear.
  2. Now at the C: prompt type “ping databaservername’
  3. Once done, press the Enter key.
  4. If you get a box saying “Ping request could not find host sql2016. Please check the name and try again,” the issue might be with the server, now you should determine the condition of the database server and restart it. After that, if you are still unable to ping it by name then try pinging it using its IP address.

Step 4: Ping using the name

In case the server pings by name and you are still getting the error, check the SQL Server Service on the database server. This is to see if that service is offline or not working anyways. 

Step 5: Check the server

Checking the server is also important. Once you get connected to the server desktop, click on the Start button and ten type ‘services.msc’ and press Enter. A window showing the Services management will appear. In the right hand pane scroll to find the SQL Server (MSSQLSERVER) service. It will show its status as “Running” well as the start up type as “Automatic”. If not, this is root cause of the problem. To fix the issue, right-click on the SQL Service to restart the device and choose Start or Restart from the drop-down menu. In case, it doesn’t start, check the credential you used to Log On As portion of the service.

If the problem still persists, it is recommended to go to Solution 2.

Solution 2

  1. Go to the Start button and open Run.
  2. There type Services.msc. Click on OK.
  3. Now look out for SQL Server (SQL Express). In case the status doesn’t start manually then right click on the Name and select Start. The process will begin
  4. Now log into your Sage 300 application.

If you still need help, feel free to call the technical experts at sagenumber.support.

Why sagenumber.support

We are a one-stop-shop to diagnose and troubleshoot all kinds of Sage errors with utmost efficiency and accuracy. We enable to get back to your business and focus on your core instead of worrying about the technical glitch. To avail our services, dial our toll-free number 1(844)-871-6289 and avail our comprehensive sage technical assistance available 24/7/365.

Leave a Reply

Your email address will not be published. Required fields are marked *